[Technical] Known Bugs & Fixes - Optimizations by clocks - TribalWar Forums
Click Here to find great hosting deals from Branzone.com


Go Back   TribalWar Forums > Archived Forums > Age of Conan
Reload this Page [Technical] Known Bugs & Fixes - Optimizations
clocks
Veteran++
Old
1 - 05-26-2008, 19:11
So, I thought a compiled list of all technical information with AoC would be useful.


Authentication Issues

Age of Conan Forums

----

Memory Leaks: If you're getting out of memory errors and gradual FPS losses during gameplay (sometimes fixed by periodically tabbing out). Shader 3.0 is the culprit for both ATI/Nvidia cards and the only fix available for the time being is setting your shader model (Video Settings -> Advanced) to 2.0 or 2.X

In some instances you'll have AoC constantly revert you back to 3.0, which can be fixed by 3rd party tools like ATI Tools (for ATI cards obviously) or Rivatuner (works with both vendors). Forcing shader model 2.0 will make the game look like ass but most have reported that it fixes the crashing issue and possibly helping preformance.

Rivatuner: RivaTuner v2.09 download from Guru3D.com
ATI Tools: ATI Tray Tools 1.3.6.1042 download from Guru3D.com

A patch for the issue is expected sometime this week, for more possible fixes:
(Sticky in the tech help forum) Age of Conan Forums

-----


Horrible FPS (Nvidia)
Age of Conan Forums

Many nVidia graphics card users are having problems with not being able to see spell (particle) effects.

What I did not know until I resolved the problem myself is that not only does the game not look as good as it should, but your FPS is also markedly lowered by this problem. If you're having this problem, try this fix that has worked for others of us:

Get Driver Sweeper and the latest nVidia drivers for your version of Windows from the links below first
Install Driver Sweeper
Go to Add/Remove Programs and Uninstall your current graphics drivers (should be named "NVIDIA Drivers" or similar)
Do not reboot if prompted
Run Driver Sweeper to remove video drivers selecting ONLY "NVIDIA - Display"
Reboot
Enter Safe Mode by pressing F8 at Windows boot time
Run Driver Sweeper again in Safe Mode selecting ONLY "NVIDIA - Display"
Reboot
Do not allow Windows to install any drivers at boot time
Check in Add/Remove Programs to see if there is an "NVIDIA Drivers" listing, if so repeat the above steps until it is gone.
Install latest ForceWare drivers (currently 175.16, linked below)
Reboot
Some users have had to do this multiple times and perhaps in slightly different orders to get things straightened out, but it is very worthwhile.

Also, the game uses "particles" for many other effects in the game, if you're having this issue then you are missing a lot of eye candy and your game is performing a lot worse than it should.

EDIT (5/20/08):
A lot of people seem to be having various performance problems with AoC and that is unfortunate. However, this fix is targetted at a specific issue with players not being able to see spell/particle effects on nVidia hardware and does not claim to resolve other performance issues.

AoC is a beautiful game. With higher graphics settings enabled it is demanding on system hardware (GPU, CPU and memory) regardless of how good your machine is. For instance I have 4GB of RAM in my 64-bit Vista machine and it's common for AoC to have allocated 1.25GB of memory and pegged one of my CPU cores at 100%. If you don't have a top-end system it's not a crime; use the performance options, that's what they're there for.

Some people seem to have been able to squeeze a few fps out of the game by cleaning the drivers as described above even though they are seeing spell/particle effects. If you're comfortable with trying this technique in order to experiment with your configuration then by all means do so, you really can't hurt anything.

At present the latest Microsoft Certified (WHQL) drivers from nVidia are 175.16 across all operating systems and these are the drivers I link to below. Some minor confusion has arisen due to people using leaked drivers with version numbers higher than 175.16. Leaked drivers have a spotty performance record in my book and I've shied away from linking them here for that reason. We're trying to solve problems not create them.

Lastly, I have seen a couple of laptop players have a difficult time finding drivers for their hardware if it's more than a couple of years old. Laptops are a special breed; if the nVidia links below do not have a driver for your hardware/OS combination, try your manufacturer's site first. If that fails try LaptopVideo2Go, google and asking here. freak1337 just made a good laptop post in this thread here (http://forums.ageofconan.com/showpos...&postcount=127).

EDIT (5/23/08):
Unfortunately a couple of people have selected their nVidia chipset drivers in addition to their nVidia graphics drivers when using Driver Sweeper. This has rendered their computers unable to boot.

"Chipset" drivers are pieces of software that your operating system (Windows) relies upon to control hardware devices such as your hard disk, networking controller, memory, etc. A device driver "drives" the device for the operating system so that the operating system doesn't have to know every detail of every piece of hardware that could possibly be attached. Logically then, a graphics driver "drives" the graphics card hardware for Windows, and in turn, the game.

The AoC problem has nothing to do with the nVidia chipset drivers and they should not be modified or removed. In order to try and avoid others making this mistake I have added a couple of links to images of the correct and incorrect options selected in Driver Sweeper. I hope that this helps to avoid others creating this problem and I'm sorry for any grief this confusion has caused.

Good luck!

jaf

Driver Sweeper at Guru3D
Guru3D - Driver Sweeper (Setup) download from Guru3D.com
CORRECT Driver Sweeper options selected:
http://img145.imageshack.us/img145/3...correctyy7.jpg
INCORRECT Driver Sweeper options selected:
http://img145.imageshack.us/img145/2...correctng5.jpg

Driver Cleaner Pro at Guru3D
A couple of people have had more success with this program than with Driver Sweeper.
Driver Cleaner Professional download from Guru3D.com

nVidia's Latest WHQL Drivers
Windows XP/XP Pro, Windows XP Media Center Edition 32-bit:
GeForce Release 175
Windows Vista 32-bit:
http://www.nvidia.com/object/winvist...5.16_whql.html
Windows Vista 64-bit:
http://www.nvidia.com/object/winvist...5.16_whql.html

Laptop users with older hardware may need to find their drivers here
LaptopVideo2Go & NVIDIA Related News

------

FPS/Flickering Issues - ATI 3800 series

It's a known issue especially with crossfire, personally I managed to fix the flickering of inventory items and issues with shader model 3.0 (crazy artifacts) by sweeping the drivers and following the guide below.

One thing to mention: FPS issues with Crossfire and 3800 series of cards is caused by the AoC client only using about 30-50% of the GPU's power, and were ****ed until Funcom or ATI does something about it.

Guide: 3850 (works with 3870's)

This install guide was written specifically for the SAPPHIRE RADEON 3850 AGP but should work if you have problems outside of sapphire. The fps fixes are for all Radeon 3850s.

INSTALL
--------

1. Use ATI uninstall
2. Reboot
3. Download Driver Cleaner Pro
4. Reboot in safe mode and run DCP to clean ATI only - DO NOT select other variants.
5. Reboot
6. Driver install
a. SAPPHIRE XP 32
b. SAPPHIRE XP 64
c. SAPPHIRE VISTA 32
d. SAPPHIRE VISTA 64
e. SAPPHIRE PCI-E
f. HIS
g. POWERCOOLER


FPS LOW FIX (fps drops when you're moving slow or not at all)
-------------

1. Download radeon3850fpsfix

2. Before step 3 save any data as sometime Winflash will black out (may require clean boot and/or several background processes closed).

3. Open Winflash

4. Save Bios

5. Open ATI bios editor

6. Load saved bios

a. Low 3d clocks should be default around 300ish. Set it to match the High 3d clock setting. This will fix the drop in frame rate when you slow down or stop moving in-game (screenshot).

b. Click the ATI 3000 series fan fix tab and increase the acceleration of your fan (screenshot).

note: Overclocking your card can cause serious damage and even **** it up all together. I personally have a single core processor and just matched the low 3d clock setting, vcore to 1.214, and enabled fan acceleration to 80%. All working fine for me in XP 32.

7. Save

8. Load new bios in Winflash

9. Click Program (Warning: you might want to back up old bios on usb drive or other media just keep in mind especially if you overclocked your card.

10. Wait a minute or so.

11. If it says successful then reboot.



FPS HIGH FIX (fps drops when you run, fight, in town, etc)--------------

1. Open Catalyst Control Center

2. Turn on triple buffering in 3d options

3. Close antivirus, firewall, and any mouse applications like setpoint.

4. Launch AoC

5. Set shader to 2.0, shadows to none, memory buffer to 101, water reflection to ground, view distance 100%. Experiment with the other settings for optimal performance.

6. While in-game alt-tab out and open Catalyst control center.

a. Method 1 - Change the minimap setting higher or lower.

b. Method 2 - Enable 3d refresh rate to a higher setting.

7. Apply and hit ok.

8. Wait 10 seconds for 3d refresh before alt-tabbing back in.

9. Your fps should climb and if not alt-tab back out and try changing another setting.

10. If your fps drops after re-zoning repeat steps 5 - 9.

note: After testing both methods I believe method 2 is actually keeping a steady gpu usage of 30-40%. Now if we could only get the other 60% working!


Using both fixes I get an fps of 10-20 in town, however in solo missions it jumps to a steady 35ish and as high as 70 when I'm not moving or walking slow.


--

Reserved for later.
 
clocks is offline
 
Last edited by clocks; 05-26-2008 at 22:30..
Sponsored Links
kyuss
K-U-R-T
Old
2 - 05-26-2008, 19:25
are there any guides on how to install this pos? i got the game @ 9:30AM, and here it is almost 3:30PM and it's not installed. sigh...

the install failed @ different cab files when i tried to install from dvd. then it failed on different cab files when i ripped the files off the dvd and tried to install from another drive. i'm currently d/ling the install files using the early access file. i must have been ****ing crazy to expect to play the game on the same day i bought it. le ****ing sigh.
 
kyuss is offline
 
clocks
Veteran++
Old
3 - 05-26-2008, 22:34
I've read that people are having the same issues with the db's on the CD, the early access is pretty much your best bet though (which your doing). I would try someone else's CD's or installing/copying from a different dvd drive.
 
clocks is offline
 
ragingbunny
VeteranX
Old
4 - 05-26-2008, 23:40
all this to play one game... lol
 
ragingbunny is offline
 
GraphiX
VeteranXV
Old
5 - 06-02-2008, 14:53
its a small tweak to make if its going to help a game you'll play for a while
 
GraphiX is offline
 
TonyElTigre
VeteranXV
Old
6 - 06-02-2008, 15:09
what a joke of a release
 
TonyElTigre is offline
 
Xero
VeteranX
Old
7 - 06-05-2008, 00:19
So after like 2 or 3 hours I finally got the game installed only to not load when i click on play. I can hear the music clipping in and out, but i never get any other screen or show anything with the game at all. Any ideas?
 
Xero is offline
 
Wrathchild
VeteranXV
Old
8 - 07-02-2008, 13:06
nvm
 
Wrathchild is offline
 
Last edited by Wrathchild; 07-02-2008 at 13:07.. Reason: durr


Go Back   TribalWar Forums > Archived Forums > Age of Conan
Reload this Page [Technical] Known Bugs & Fixes - Optimizations

Social Website Bullshit


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


AGENT: CCBot/2.0 (https://commoncrawl.org/faq/) / Y
All times are GMT -4. The time now is 05:21.