Post your rigs, TW!! by Fonzie - Page 11 - TribalWar Forums
Click Here to find great hosting deals from Branzone.com


Go Back   TribalWar Forums > TribalWar Community > TW Music Collective
Reload this Page Post your rigs, TW!!
Page 11 of 11
Thread Tools
old_skul
UVALAN++
Contributor
Old
201 - 02-03-2014, 03:43 PM
Reply With Quote
Quote:
Originally Posted by soggynuts View Post
Mine is effed up right now. For some reason one of the tubes blew and when I removed it, the little port that the tube plugs into has a black spot like two of the pins arced. I'm not sure what the hell happened but now even after replacing both tubes, only one tube glows when I turn it on. I don't have the cash to get it repaired right now but hopefully next month I can get it taken care of.
Probably blew the screen resistor when the arc happened. Be happy; a screen resistor is a lot cheaper to replace than a transformer. It's an easy fix for a tech.

Super nice amp. Why in the world would you pull a tube while it was on?
 
old_skul is offline
 
Sponsored Links
soggynuts
VeteranXV
Old
202 - 02-03-2014, 04:39 PM
Reply With Quote
Quote:
Originally Posted by old_skul View Post
Probably blew the screen resistor when the arc happened. Be happy; a screen resistor is a lot cheaper to replace than a transformer. It's an easy fix for a tech.

Super nice amp. Why in the world would you pull a tube while it was on?
oh no! I didn't pull a tube while it was on, absolutely woudl never do that.

It was only working on the diode position, but was blowing fuses (and then not working anymore) when I bought it. Guitar center ripped me off, and wouldn't take it back or repair it.

I talked to a friend who said to replace the tubes, so I did that, and noticed there was some black char as if two of the tube pins arced. I replaced the tubes and it appeared to be working, but one of the tubes wasn't glowing.

Since then, someone messed with my amp in my studio while I wasn't there (furious about this but nothing I can do), and now only the clean channel works. I need to take it in to get fixed. I need to do a lot of things right now, I'm a little behind on life.
 
soggynuts is offline
 
Page 11 of 11
Reply


Go Back   TribalWar Forums > TribalWar Community > TW Music Collective
Reload this Page Post your rigs, TW!!

Social Website Bullshit

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

AGENT: CCBot/2.0 (http://commoncrawl.org/faq/) / Y
All times are GMT -5. The time now is 06:05 AM.